CakePHP 3

 先日、PHPのフレームワーク「CakePHP」のバージョン3がリリースされました。

 私はまだ本格的に触っていないので詳細な情報はわからないのですが、モデル(Model)周りが大きく変わったような情報があります。また、バージョン2よりもかなり良くなったような情報もありますので、どこかのタイミングで本格的に触ってみたいと思います。

 そんなバージョン3のCakePHP 3をインストールするにはいくつかの条件がありますので、メモがてら下記に明記しておきます。

  • HTTP Server(例えばApache、mod_rewriteがあれば理想)
  • PHP 5.4.16以上
  • mbstringとintl
  • データベース(DB)
    下記のDBのいずれか

    • MySQL:5.1.10以上
    • PostgreSQL:特記無し
    • Microsoft SQL Server:2008以上
    • SQLite:3以上

 必須かどうかというと必須じゃないとは思うのですが、バージョン3からComposerを使ったインストールとなったようです。Composerを使わなくてもインストールはできると思うのですが、まだよくわかったいません。

Composer

 詳細はCakePHPのドキュメントに明記されていますが、本記事を書いている時点では英語のみの提供です。

Installation — CakePHP Cookbook 3.x documentation

アマゾンのサーバでエラーが起こっているかもしれません。
一度ページを再読み込みしてみてください。